Introducing, our NEW WE Connect Portal for OfficeSuite UC®!

click here for more info!

WE Connect portal vs MyOfficeSuite, What has changed?

read more...

ATTENTION: All Android users utilizing PingID to access Windstream Enterprise services.

ATTENTION: All Android users utilizing PingID to access Windstream Enterprise services. You must upgrade your PingID App to version 1.9.1 prior to March 1, 2020, or your access will cease to work.

Google recently announced that all Android users utilizing PingID must upgrade their PingID App to version 1.9.1 prior to March 1, 2020.

Q: What is the impact?

A: To continue to access Windstream Enterprise Services requiring 2-factor authentication (including SD-WAN, Meraki LAN, and Managed Network Security), you must upgrade your PingID App to version 1.9.1 prior to March 1, 2020. 

Q: Who is impacted?

A: Android users only.

Q: What is the resolution?

A: Prior to (and including) March 1, 2020, download and install the PingID App 1.9.1 to your Android device. 

Q. What if I don’t update prior to March 1, 2020?

A: Your current MFA will cease to work, and you will not be able access and manage your Windstream Enterprise services through MFA. You must contact Windstream Customer Care to reestablish MFA. You will be instructed to unpair your device from the MFA application, confirm that you have upgraded to the most current PingID App and then pair the device again after the upgrade.

Q. Why must I upgrade my PingID App?

A: Google is upgrading their security standards to increase the privacy safeguards for PingID users with Android devices.

Please contact us at 800.600.5050 if you have any questions.

This discussion has been closed.